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Preface

NEXIO™ NXOS™ and PlayList™ Tutorial

Purpose
This tutorial provides operating instructions for the NXOS and 
PlayList applications.  The guide can also be used as a convenient 
reference tool for all application and user interface functions.  

Audience
This tutorial is written for operators and technicians responsible for the 
operation of the NXOS and PlayList applications.  The guide also 
includes advanced sections applicable to a system administrator.   

Copyright 
© 2004, Leitch Technology, Inc.  All rights reserved.

Trademarks
Leitch is a registered trademark of Leitch Technology Corporation that 
may be registered in some jurisdictions.  NEXIO, NXOS, MediaBase 
and PlayList are either registered trademarks or trademarks of Leitch 
Technology Corporation in the U.S. and/or other countries.

Notice
Information in this tutorial is subject to change without notice or 
obligation.
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Chapter 1

Introduction

Overview
This tutorial provides hands-on operating instructions for the NEXIO 
NXOS and PlayList applications.  

• NXOS is a standard application that is pre-installed on every 
NEXIO server system.  

• PlayList is an optional application that requires a dongle for 
proper operation.

All features and functions of both applications are covered.

How to Use This Tutorial
Use this tutorial as a step-by step guide for learning how to operate the 
NXOS and PlayList applications.  

• Read the “NXOS Orientation” and “PlayList Orientation” 
chapters first.  These will familiarize you with all of the 
system’s windows, features and functions.  

• Next, follow the steps in the “Using NXOS” and “Using 
PlayList” chapters to practice each mode and function.  

As you read each chapter, it is recommended that you have a server 
system available so that you can try each procedure.  Please note:

• Hyperlinks — You will find numerous blue hyperlinks 
throughout the text.  To assist you with navigating the sections 
and locating the information quickly, simply click a hyperlink 
to jump to the section.
NXOS and PlayList Tutorial 1



 Chapter 1: Introduction
• Table of Contents — For PDF and on-line versions of this 
tutorial, the Table of Contents is fully hyperlinked.

• Index — Use the Index as a good first step in locating 
information quickly.  Multi-level index marks are provided.  In 
the PDF and on-line versions, the index is fully hyperlinked.  

In This Tutorial
The following chapters are included in this tutorial:

• Chapter 1, “Introduction” outlines the tutorial, introduces each 
product and provides technical support numbers.  Instructions 
for login are also provided.

• Chapter 2, “NXOS Orientation” introduces you to all aspects of 
the NXOS user interface. 

• Chapter 3, “PlayList Orientation” introduces you to all aspects 
of the PlayList Window.

• Chapter 4, “Using NXOS” provides step-by-step instructions 
for all basic NXOS functions.

• Chapter 5, “Using PlayList” provides step-by-step instructions 
for all basic PlayList functions.

• Chapter 6. “Traffic Functions” outlines various methods for 
working with traffic files and filters. 

• Chapter 7, “Advanced Operations” covers advanced procedures 
typically performed by the System Administrator.

Prerequisites
As a prerequisite for using this tutorial, ensure that one of the following 
NEXIO servers is available for your use:

• NX4000TXS Shared Storage Transmission Server
• NX4000ITS Integrated Storage Transmission Server

Ensure that a keyboard, mouse and VGA monitor are connected to the 
NEXIO server.  Most important, ensure that a video source is connected 
to the server, and that audio/video monitoring is connected to the 
server’s outputs. This will allow you to record (ingest) material, and 
verify audio and video playback.  
Finally, check with your System Administrator that a password and 
User ID have been set up for you. 
2 NXOS and PlayList Tutorial



 Chapter 1: Introduction
About NXOS
The NXOS application is the built-in operating system for all NEXIO 
servers.  With NXOS, you can digitize clips from a VTR (connected via 
RS-422), encode content from live sources such as a network or satellite 
feed, and create “sub-clips” from parent clips. 
All content is stored in MediaBase, the server’s own information 
database.  With MediaBase, you can sort your clips with a variety of 
standard and custom “views,” and instantly play back clips with the 
system’s Channel Control Windows.
Refer to the “NXOS Orientation” chapter for full details. 

About PlayList
PlayList is an option to the NXOS application that runs within NXOS 
itself — it does not have a separate desktop icon.  Playlist provides clip 
playout capability on as many as four NEXIO channels simultaneously.  
Its comprehensive features give customers a flexible and convenient 
automation system for use in basic playout, commercial insertion, 
backup and emergency playout configurations.  
You can add clips to PlayList directly from MediaBase, by ID, or from 
an imported traffic list. GPI trigger and timed event playout capabilities 
are also included.
Refer to the “PlayList Orientation” chapter for full details.

For Technical Assistance
Leitch is committed to providing round-the-clock, 24-hour service to 
our customers around the world for Server, Video Processing and 
Distribution products.  If you require assistance with the NXOS or 
PlayList applications, contact information is listed below: 

• Phone:  +1 (818) 843-7004  
• Toll Free:  +1 (888) 843-7004
• Fax:  +1 (818) 450-2199
• Email:  service.servers@leitch.com
• Website:  www.leitch.com
NXOS and PlayList Tutorial 3
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 Chapter 1: Introduction
Logon
Use the following steps to log on to the NXOS and Playlist application: 
1. When you start the NEXIO server, the LLM (Low Level Module) 

automatically initializes and the Logon Dialog appears.  However, 
if the server is already on, double-click the Nexio Startup shortcut 
on the desktop. 

Figure 1-1. Nexio Startup Shortcut

The Logon Dialog appears, as shown in the sample below:

Figure 1-2. Logon Dialog

2. Under the “Accounts” column, click your name (User ID), enter 
your password and then click Login.  Passwords are case sensitive.

3. The NXOS Main Screen appears.  If you need to logout or change 
users, from the Main Screen’s Menu Bar, click File > Logout to 
display the Logon Dialog.

4. Repeat step 2 to change users, or click Exit to log off.
5. Please continue with Chapter 2, “NXOS Orientation.”   

Note
If this is the very first time that 
the NXOS and PlayList 
applications have been used, 
refer to the “First Time Logon” 
section in Chapter 7 for 
instructions. 

Note
If you don’t already have a 
password and User ID, ask your 
System Administrator to set 
them up for you.
4 NXOS and PlayList Tutorial



Chapter 2

NXOS Orientation

In This Chapter
This chapter provides a comprehensive introduction to the NXOS user 
interface.  Each section is designed to familiarize you with all windows, 
functions and buttons.  
The following topics are discussed: 

• NXOS Main Screen
• Menu Bar
• NXOS Tool Bar
• MediaBase Tree
• Message Bar
• Channel Control Window
• Transport Menu
• Function Section
• Channels Menu
• Audio Section
• Compression Settings
• MediaBase Window
• Digitize Window
• TapeBase Window
• GPI Window
NXOS and PlayList Tutorial 5



 Chapter 2: NXOS Orientation
NXOS Main Screen
The figure below illustrates the NXOS Main Screen:

Figure 2-1. NXOS Main Screen

Descriptions of each section are provided below.
1) The Menu Bar provides direct access to NXOS and PlayList 

commands and dialogs.  Refer to the “Menu Bar” section for 
complete information. 

2) The Tool Bar provides single-click access to common functions.  
Two bars are provided (one each for NXOS and PlayList), and each 
can be displayed or hidden.  Refer to the “NXOS Tool Bar” section 
for details.

1) Menu Bar 3) MediaBase Tree 5) Channel Control Window

2) Tool Bar 4) Message Bar 6) MediaBase Window

1

2

3

4

5

6
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 Chapter 2: NXOS Orientation
3) The MediaBase Tree allows you to view clips in the database 
using a variety of convenient text-based “views.”  Refer to the 
“MediaBase Tree” section for information.

4) The Message Bar provides text-based help for Tool Bar buttons.  
Refer to the “Message Bar” section for details.

5) The Channel Control Window enables you to digitize live 
sources, play and trim clips, review clip properties and generate 
subclips.  Depending on your server’s configuration, up to four 
windows are available — one for each server channel.  Refer to the 
“Channel Control Window” section for complete information. 

6) The MediaBase Window shows all clips in the database.  Clips 
can be sorted by column, and the columns themselves can be 
enabled, disabled, sized and moved.  Refer to the “MediaBase 
Window” section for more information.

Menu Bar
The figure below illustrates the Menu Bar:

Figure 2-2. MediaBase Menu Bar

The Menu Bar provides direct access to MediaBase and Playlist 
functions.  Note that the MediaBase label changes depending on the 
window that is selected:

• When any MediaBase view is selected, the bar appears as 
shown above.

• When a Channel Control Window is selected, the label changes 
to “Channels.”  See the “Channels Menu” section for details.

• When a Playlist Window is selected, the label changes to 
“Playlist.”  Refer to the “Using PlayList” chapter for Playlist 
Menu details.

• When the TapeBase Window is selected, the label changes to 
“TapeBase.”  Refer to the “TapeBase Window” the section for 
details.  

Following are descriptions of all MediaBase menus.
NXOS and PlayList Tutorial 7



 Chapter 2: NXOS Orientation
File Menu
The File Menu is shown below:

Figure 2-3. File Menu

• Click File > New PlayList to open a new PlayList Window.
• Click File > Open PlayList to display the Open Dialog, 

where you can open a PlayList that was saved to disk.
• Click File > Logout to display the Logon Dialog, where you 

can change users or exit the program.
• Click File > Exit to close the application. 

View Menu
The View Menu is shown below:

Figure 2-4. View Menu

• Click View > Toolbar to show or hide the NXOS Tool Bar.  
The PlayList Tool Bar (if visible) is not affected.
8 NXOS and PlayList Tutorial



 Chapter 2: NXOS Orientation
• Click View > Status Bar to show or hide the Status Bar for 
the currently selected window — either for the MediaBase, 
Channel Control, PlayList or Digitize Window.  When 
enabled, the bar appears at the bottom of the selected window. 

• Click View > Side Bar to show or hide the MediaBase Tree.
• Click View > Digitize Window to show the Digitize 

Window.  See the “Digitize Window” section for information.
• Click View > GPI Setup to show the GPI Window.  Refer to 

the “GPI Window” section for details.
• Click View > Playlist > New Playlist to open a new 

PlayList Window.  Refer to Chapter 3, “PlayList Orientation” 
for information.

• Click View > Remaining Space to display the Space 
Remaining Dialog, as shown in the sample below.

Figure 2-5. Space Remaining Dialog

One status line is shown for each channel in your system, 
including data on space remaining, bit rate, audio and VBI.

• Click View > TapeBase to display the TapeBase Window.  
Refer to the “TapeBase Window” section for details.

• Click View > VR Channel > [Channel Name] or press F9 
through F12 to show the selected Channel Control Window.  
One line appears in the sub-menu for each channel in your 
system.  This function is typically used to bring a hidden (or 
closed) channel to the foreground.
NXOS and PlayList Tutorial 9
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MediaBase Menu
The MediaBase Menu is shown below:

Figure 2-6. MediaBase Menu

• Click MediaBase > Search (or press Ctrl + F) to display the 
Find Dialog, which allows you to search the MediaBase.

Figure 2-7. Find Dialog

Enter the text that you wish to locate, select the desired options 
and click Find Next.

• Click MediaBase > Select All (or press Ctrl + A) to 
highlight all clips in the MediaBase.

• Click MediaBase > Export to display the Save MediaBase 
As Dialog, in which you can save the contents of the 
MediaBase to disk in XML format.

Note that Consolidate Media and Delete List are advanced 
functions for administrative use only.  In Chapter 7, refer to the 
“Consolidating Clips” and “Deleting Clips” sections for details.
10 NXOS and PlayList Tutorial
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User Settings Menu
The User Settings Menu is shown below:

Figure 2-8. 

• Click User Settings > User > Logoff to display the Logon 
Dialog in which you can log out or change users.  

Note that Change Password and Modify Settings are advanced 
functions for administrative use only.  Refer to the “Advanced 
Operations” chapter for details.

Window Menu
The Window Menu is shown below:

Figure 2-9. Window Menu

• Click Window > Cascade to cascade all open windows 
visible in the Main Screen.

• Click Window > Tile to tile all open windows visible in the 
Main Screen.  MediaBase windows are resized as required.

• Click Window > Arrange Icons to arrange any minimized 
window icons at the bottom of the Main Screen.
NXOS and PlayList Tutorial 11



 Chapter 2: NXOS Orientation
Help Menu
The Help Menu is shown below:

Figure 2-10. Help Menu

• Click Help > About VROS to display the About Dialog 
which lists program, version, copyright, memory and disk 
space information.

NXOS Tool Bar
The figure below illustrates the NXOS Tool Bar:

Figure 2-11. NXOS Tool Bar

Descriptions of each button are provided below:
1) Click the Channel button to open the selected Channel Control 

Window (if closed), or bring a hidden window to the foreground.  
One button is provided for each channel.

2) Click the New PlayList button to open a new (empty) PlayList 
Window.  Refer to Chapter 3, “PlayList Orientation” for details.

3) Click the MediaBase button to open the MediaBase Window (if 
closed), or bring it to the foreground if hidden.  Refer to the 
“MediaBase Window” section for more information.

4) Click the Digitize button to display the Digitize Window.  See the 
“Digitize Window” section for details.

1) Channel 4) Digitize 7) Search

2) New PlayList 5) TapeBase 8) Load

3) MediaBase 6) GPI Setup 9) Delete List

1 2 4 6 83 5 7 9
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5) Click the TapeBase button to show the TapeBase Window.  See 
the “TapeBase Window” section for details.

6) Click the GPI Setup button to display the GPI Window.  Refer to 
the “GPI Window” section.

7) Click the Search button to display the Find Dialog, in which you 
can search the MediaBase.  The MediaBase Window must be 
selected for the button to be active.

8) Click Load to load and play a highlighted clip in the MediaBase 
Window.  As a prerequisite, select the desired output channel with 
the pull-down arrow (to the right of the Load button).  Clicking 
Load immediately overrides any clip playing in that channel.

9) Click Delete List to display the Delete List Window, which 
enables users with “admin” priveleges to delete clips based on an 
imported list.  In Chapter 7, refer to the “Using the Delete List 
Window” section for details.

To change the size of the icons, right-click anywhere on the Tool Bar to 
display the Tool Bar Pop-up Menu:

Figure 2-12. Tool Bar Pop-up Menu

Click the desired icon size.  

Note
Tool Tip help is available for all 
Tool Bar buttons.
NXOS and PlayList Tutorial 13
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MediaBase Tree
The figure below illustrates the MediaBase Tree:

Figure 2-13. MediaBase Tree

The MediaBase Tree offers many different views into the MediaBase.  
Double-click any line in the tree to display a window containing only 
that category of clips, such as Audio-Only or SubClips.  Double-click 
the MediaBase line at the top to display the entire MediaBase Window.
MediaBase windows are populated automatically, based on various 
criteria at the time of ingest or subclip creation.  For example:

• Clips ingested today appear in the “Today’s Media” folder.
• Clips ingested by the logged-in user appear in the “My Media” 

folder.
• If the “Agency” field is completed (in a clip’s Properties 

Dialog), a folder for each listed agency appears under the “By 
Agency” folder.

Please note:
• Clips may reside in one or more windows.
• Click and drag the top edge of the tree to un-dock it from the 

left edge of the screen, and place it anywhere on screen.  
• The tree can be re-sized by clicking and dragging its edges.
14 NXOS and PlayList Tutorial
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• Click the Channels button at the bottom of the tree to display 
channel status:

 
Figure 2-14. Channel Status

Message Bar
The left-hand edge of the Message Bar displays help text when 
selected Menu Bar items are chosen, as shown in the sample below.  
The right-hand edge of the bar also shows the current logged in user.

Figure 2-15. Message Bar Help Text (sample)
NXOS and PlayList Tutorial 15
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Channel Control Window
The Channel Control Window is your main interface for ingesting live 
material.  A sample window is shown below:

Figure 2-16. Channel Control Window

Descriptions of each section and button are provided below:
1) The Mark In Section provides controls for marking and trimming 

the clip’s inpoint.  
• Click Mark to mark an inpoint on the fly.
• Click Goto to search to the marked inpoint.
• Click inside the Timecode field, and enter an entry point 

or a “goto” point.  Numbers shift left as you enter them.
• Click  to subtract one frame from the marked inpoint. 

Click  to add one frame to the marked inpoint. 

2

1 3

54

6

7

1) Mark In Section 4) Transport Control Section 7) Function Section

2) Timecode Section 5) Audio Button

3) Mark Out Section 6) Data Section
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2) The Timecode section displays the clip’s timecode position, 
format (DF or NDF), and the percentage of playback speed.  

• Click and drag the Shuttle control to shuttle the clip 
forwards and backwards. The direction and speed are 
shown as you move the control  

• When you release the Shuttle control, it springs back to 
center (pause mode).

3) The Mark Out Section provides controls for marking and 
trimming the clip’s outpoint.  Controls are identical to those in the 
Mark In Section — except the outpoint is affected.

4) The Transport Control Section provides VTR-like controls:

Click Rewind to shuttle the clip at full-speed reverse.

Click Reverse to play at one times play speed, in 
reverse.

Click Step Left to jog backwards by the current “jog 
interval.”  See the “Transport Menu” section for details.  

Click Pause to stop clip playback on a freeze frame.

Click Step Right to jog forwards by the current “jog 
interval.”  See the “Transport Menu” section for details.

Click Play to play the clip at one times play, forward.

Click Fast Forward to shuttle the clip at full-speed 
forward.

Click Stop to stop clip playback and display input 
video (EE mode).

The Record button is half red, half yellow when a new 
clip is record-enabled.  To record, click and hold the 
left mouse button, then tap the right mouse button.
The Record button turns full red when the channel is 
recording.  The button is grayed-out when the channel 
is in playback mode.
NXOS and PlayList Tutorial 17
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5) Click the Audio button to open and close the window’s Audio 
Section.  Refer to the “Audio Section” below for details.

6) The Data Section displays clip information, including ID, 
description, format, GOP structure and bitrate.

• To playback a clip, drag and drop a clip into the ID field — 
directly from any MediaBase window.

• You can also click Load ID, and add a clip by name from 
the Load ID Dialog.  See the “Load ID” section for details.

• When you click Add ID to record a clip, the information in 
the New ID Dialog is used to populate the fields in the Data 
Section.  See the “Add ID” section for details.

7) The Function Section includes four buttons used to create new 
clip IDs, playback clips, trim and create subclips.  Refer to the 
“Function Section” below for details.

Transport Menu
Right-click the Step Left or Step Right button to display the 
Transport Pop-up Menu:

Figure 2-17. Transport Pop-up Menu

• Click Frame Increment Distance to display the Frame 
Increment Distance Dialog.

Figure 2-18. Frame Increment Distance Dialog

Note
If you drag and drop an MPEG 
clip into a channel configured 
for DV (and vice-versa), you 
will get a warning dialog.
18 NXOS and PlayList Tutorial
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Enter the desired interval (in frames) and click OK.  When 
Step Left or Step Right is clicked, the clip jogs by the 
selected interval.

Function Section
The Function Section includes four buttons and a check box that are 
used to record, playback, trim and create subclips.  

Figure 2-19. Function Section

Each button is described below.  Refer to the “Add ID,” “Load ID,” 
“Trim,” Sub Clip,” or “SDTI” sections for details.

Add ID
The “Add ID” function creates a new clip ID for recording, but does 
not create the actual media.  Material is added to the ID when you click 
Record.
To create a new ID, click Add ID.  The New ID Dialog appears:

Figure 2-20. New ID Dialog

• Fields are provided for clip name (ID), an optional description, 
kill date and agency.  The ID field is required.
NXOS and PlayList Tutorial 19
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• If the “Open Ended” check box is enabled and you leave the 
duration at 00:00:00:00, the clip will be open ended. 
Open-ended recordings end when they are stopped manually. 

• If you enter a duration in the DUR field, duration will be 
obeyed, even if Open Ended is checked.

• To change the clip’s format, GOP structure and bit rate, click 
Compression Settings to display the Compression 
Settings Dialog.  Refer to the “Compression Settings” section 
for details. 

• When all desired settings have been entered, click OK to create 
the “empty” ID, in preparation for recording.

Load ID
To load a clip for playback using its ID, click Load ID to display the 
Load ID Dialog:

Figure 2-21. Load ID Dialog

Enter the desired clip name and click OK.  The entry is case-sensitive.  
Please note:

• Once the clip is loaded, the Load ID button changes to 
Unload ID.  Click Unload ID to unload the clip from the 
channel.  

• To unload the current clip, you can also drag and drop a clip 
into the ID field, replacing the current one.  

Trim
The Trim function is used to trim unwanted frames from the beginning 
and end (head and tail) of a clip or subclip.  Note:

• When you trim a parent clip or a single clip, the trim process is 
permanent.  The unwanted frames are deleted from the server.
20 NXOS and PlayList Tutorial
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• When you trim a subclip, the “pointers” to the original frames 
on the parent clip are moved — rather than deleted.

To prepare a clip for trimming, the trim mode must be enabled.  Right 
click the Trim button to display the Trim Pop-up Menu:

Figure 2-22. Trim Pop-up Menu

With the clip enabled for trimming, shuttle or jog the clip to the desired 
inpoint or outpoint, and then Mark the point.  Depending on the 
selected point, the Mark In, Mark Out, or Duration field appears red 
as shown in the sample below:

Figure 2-23. Marked Outpoint in Trim Mode

To mark a point, you can also enter a timecode in the inpoint or outpoint 
field, click Goto, and then click Mark.
To complete the trim procedure, click Trim.  When the Warning 
Dialog appears, click Yes.
If you do not want to trim the clip, you have several options:

• Disable the trim mode.
• Unload the clip.
• Load a different clip.
NXOS and PlayList Tutorial 21
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Sub Clip
A subclip is a portion of an existing ID (parent clip) with its own 
MediaBase entry.  A subclip is defined by “pointers” that reference 
frames on the parent clip, and thus, no additional media is stored on the 
server.  You can make subclips from parent clips or other subclips. 
The “Auto ID Options” setting in the Channels Menu affects how 
subclips are named.  See the “Auto ID Options” section for details. 
To create a subclip, load a clip into a Channel Control Window, mark a 
new inpoint and outpoint (as required), and click Sub Clip to display 
the Create SubClip Dialog.

Figure 2-24. Create SubClip Dialog

Your new marked points are automatically entered in the In TC and 
Out TC fields, and the new Duration is also shown. 
Change the new ID (if desired), enter an optional description, and click 
OK to create the subclip.  The subclip is entered in the MediaBase and 
is now available for playout.  Please note:

• A special “subclip” icon denotes the subclip in the MediaBase.
• You can create an unlimited number of subclips from the 

original parent.
• Subclips can be deleted or trimmed in the normal manner. 
• A parent ID can not be deleted (or trimmed) until all of its 

associated subclips have been deleted. 
22 NXOS and PlayList Tutorial



 Chapter 2: NXOS Orientation
SDTI
When the channel is set to DV, enable the SDTI check box to ingest an 
SDTI stream and automatically convert it to DV format.  An SDTI 
source (such as a SDTI compatible tape deck) is required.  Several 
models of SDTI decks are supported.  Please contact Leitch Technical 
Support for details.  Please note:

• 1x and 4x normal speed transfers are supported for DV25.
• 1x normal speed transfer is supported for DV50.

Transfer speeds must be selected at the SDTI tape deck itself.  

Channels Menu
The Channels Menu enables you to set a variety of Channel Control 
Window options. 

Figure 2-25. Channels Menu

• Click Channels > MarkIn Offset to set a frame value that is 
subtracted from the marked inpoint. The Mark In Offset 
Dialog appears:

Figure 2-26. Mark In Offset Dialog

Note
An SDTI stream can only be 
ingested when the server 
channel is set to DV.  Contact 
your System Administrator for 
assistance with channel format.
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Enter a value greater than 0 frames and click OK.  For example, 
if you click Mark at 01:04 and there is an offset of 3, the 
marked value will be 01:01.  

• Click Channels > MarkOut Offset to set a frame value that 
is subtracted from the marked outpoint.  Enter the desired value 
in the Mark Out Offset Dialog and click OK.

• Click Channels > Compression Settings to display the 
Compression Settings Dialog.  Refer to the “Compression 
Settings” section for details.

• Click Channels > Auto ID Options to display the Auto ID 
Options Sub-menu.  This menu allows you to assign automatic 
names to subclips.  See the “Auto ID Options” section below 
for details.

• Click Channels > Record Termination Warning to 
enable or disable the record termination warning.  When 
disabled, recording stop immediately when the Space Bar is 
pressed.  When enabled, pressing the Space Bar while a 
channel is recording displays a Warning Dialog: 

Figure 2-27. Record Termination Warning 

Auto ID Options
The Auto ID Options Sub-menu determines how subclips are named. 

Figure 2-28. Auto ID Options Sub-menu

• Enable the Auto ID Increment function to assign an 
automatic name to each new subclip.  This name appears in the 
SubClip ID field (in the Create SubClip Dialog).  
24 NXOS and PlayList Tutorial
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• Disable the Auto ID Increment function to assign your own 
ID to the new subclip. 

The “automatic” ID is based on two factors: the original clip name and 
the current ID Length.  To change the ID length, click the ID Length = 
[n] field.  The AutoIncrement ID Length Dialog appears:

Figure 2-29. AutoIncrement ID Length Dialog

Enter the new auto ID length (greater than 4 characters) and click OK.
For example, if the ID length is set to 4, the fourth character in the 
“parent” clip name will automatically increment.  If the ID length is set 
to 5, the fifth character will increment.  
Following are two examples:

• ID length = 4.  Parent clip name = PSA1.  New auto subclip 
name = PSA2. 

• ID length = 7.  Parent clip name = America.  New auto subclip 
name = Americb.
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Audio Section
In the Channel Control Window, click the Audio button to open and 
close the window’s Audio Section.  When open, audio input and output 
levels can be set and monitored, and various functions can be set.

Figure 2-30. Channel Control Window with Open Audio Section

Please note the following important points:
• Format — Each video channel has four-channel AES/EBU or 

embedded audio capability.  Four VU meters are always shown.  
• Levels — Output levels are displayed when a clip is playing or 

paused.  Input levels (EE) are displayed when the channel is 
empty (clips unloaded), in record mode or stopped. 

• Sliders — The triangular “sliders” are used to adjust input and 
output levels.  Click and drag the desired slider, and note that 
the readout below the meter adjusts accordingly.  

A variety of right-click functions are also available as discussed below 
in the following sections:

• Channel Reference, Latency and Background
• Unity and Gang

Note
Audio input configuration, 
sample rates and “slider” 
activation are set with the VR 
Manager.  Contact your System 
Administrator for assistance 
with audio channel setup.
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Channel Reference, Latency and Background
To change the reference scale for all four channels, right-click the “db” 
scale to display the Audio Reference Pop-up Menu. 

Figure 2-31. Audio Reference Pop-up Menu

• Click 0 Reference to set the reference scale to 0db.
• Click -20 Reference to set the reference scale to -20db.

Note that changes to the scale have no effect on audio levels.
To change the meter’s peak latency, click Peak Latency to display the 
Peak Latency Sub-menu.

Figure 2-32. Peak Latency Sub-menu

Select the time interval that you want peak levels to hold on the 
channel’s meters.
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To change the background of the meters to black, enable the Black 
Background option.

Figure 2-33. Meters with Black Background

To set them back again, un-check the option.

Unity and Gang
Right-click inside any VU meter bar to display the Unity Pop-up 
Menu.  The meter in which you clicked will be affected.

 
Figure 2-34. Unity Pop-up Menu

• Click Unity to return the selected channel (or ganged channels) 
to unity gain.

• Click Gang to display the Gang Pop-up Menu.

Figure 2-35. Gang Pop-up Menu
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Click a color for the first channel that you want to gang, then 
repeat the procedure — choosing the same color for additional 
channels that you wish to “connect” to the first. Ganged 
channels adjust as one, as shown in the sample below:

Figure 2-36. Ganged Channels

Note that if you set up an offset between un-ganged channels 
and then gang them together, the offset is maintained.

• To un-gang a channel, right-click a meter to display the Unity 
Pop-up Menu, click Gang to display the Gang Pop-up 
Menu, and then click Not Ganged.
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Compression Settings
Typically, a facility standardizes on one video format and its associated 
compression settings, and then retains those settings for almost all 
recordings.  However, if the settings need to be changed, the 
Compression Settings Dialog is used.
The Compression Settings Dialog can be accessed from two different 
system windows:

• When digitizing from a live source, from the Channel Control 
Window click Add ID to display the New ID Dialog.  Then 
click Compression Settings.

• When digitizing from tape, on the Tool Bar click the Digitize 
icon to display the Digitize Window.  Then click 
Compression Settings.

A sample Compression Settings Dialog is shown below:

Figure 2-37. Compression Settings Dialog

In the dialog, you can enable or disable VBI, select a drive and view 
time remaining on the server.  

• If the channel’s codec is set to DV format, you can choose 
between DV25 and DV50 recording format. 
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• If the channel’s codec is set to MPEG format, you can change 
settings by clicking the MPEG Settings button to display the 
MPEG Settings Dialog.

Figure 2-38. MPEG Settings Dialog

In the dialog, select a profile, bit rate and GOP structure and 
click OK.  Consult with one of your facility’s video engineers if 
you need assistance with MPEG settings.

• All new settings will be reflected in the New ID Dialog, and 
will be applied to the new recording. 

Note
The codec’s recording format 
(DV or MPEG) cannot be 
changed by the user.  Contact 
your System Administrator for 
assistance with channel format.
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MediaBase Window
The figure below illustrates a sample MediaBase Window:

Figure 2-39. MediaBase Window

The MediaBase Window displays the entire inventory of clip and 
subclip IDs available for playback on the server.  Using the window, 
you can:

• Customize the appearance of the MediaBase, sort by column 
and rearrange the order of columns.  Refer to the “MediaBase 
View” section for details.

• Browse clips and subclips on the server.  See the “MediaBase 
Browse” section for information.

• View and change a clip’s properties (ID, Description, Agency, 
Kill Date, Type and User Fields).  See the “MediaBase 
Properties” section for information.

• Manage the database by deleting IDs that are no longer 
required.  This function can only be performed by the System 
Administrator and users with “delete” privileges.  Refer to the 
“Advanced Operations” chapter for details.

Note
The information in this section 
describing the MediaBase 
Window applies to all windows 
in the MediaBase Tree.
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MediaBase View
This section describes how you can “read” the MediaBase Window, sort 
and rearrange the columns, and customize the fields shown.  The 
following topics are discussed:

• Icons
• Sort and Arrange Columns
• Customize MediaBase Fields

Icons
The first column in any MediaBase Window displays an icon that 
visually identifies the type of clip.  Please note:

• The icon column cannot be moved or hidden.
• Tool-tip help is provided when you mouse over the icons.

Icon descriptions are listed below:

Table 2-1. MediaBase Window Icons  

Icon Description
Audio Only — This clip contains audio plus data, but no 
video. The clip can be loaded in a Channel Control Window, 
but cannot be used in a PlayList.

Clip Sync — The playout of the clip is synchronized with 
another clip using the Clip Sync application.  This type of clip 
is currently not implemented.

Consolidated With Macros — A clip consolidated with 
macros plays back without any black between the separate 
subclips.  This clip type can be played in a Channel Control 
Window, but not in a PlayList.

Consolidated Without Macros — A clip consolidated without 
macros plays back with black between the separate subclips.  
The length of black depends on the time between subclips on 
the parent clip.  This clip type can be played in a Channel 
Control Window, but not in a PlayList.  

Crawl — A Crawl is a special “title” file for NewsFlash use.  It 
cannot be used by NXOS or PlayList.
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Edit ID — Same as a Single clip, but the clip has been ingested 
(or manipulated) by either NewsFlash, Instant Online or 
BrowseCutter.  This type of clip is currently not implemented.

Empty Container — This clip type is used by the RunDown 
Manager as a placeholder for video that will be ingested at a 
later time.  The clip is an ID only with no media.  This type of 
clip is currently not implemented.

Hidden — The Hidden subclip type is currently not 
implemented.

Media — Information to be provided.

NewsFlash Project File — This type of clip cannot be used by 
NXOS or PlayList.

Parent — A Parent clip contains audio and video plus data, but 
the clip acts as the “parent” source to one or more subclips.

Protected Project — Information to be provided. 

RGB — Information to be provided.

Roll — A Roll is a special “title” file for NewsFlash use.  It 
cannot be used by NXOS or PlayList.

Single — A Single clip contains audio and video plus data.  
The clip has no associated subclips.

Sliding — This clip indicates a looped duration-based 
recording.  The clip has the same properties as a Single clip, but 
when the assigned duration is reached, the recording loops 
back and overwrites the media from the inpoint forward.  This 
type of clip is currently not implemented.

Still — A Still is a single-frame graphic file for NewsFlash use.  
It cannot be used by NXOS or PlayList.

Table 2-1. MediaBase Window Icons  (Continued)

Icon Description
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Sort and Arrange Columns
The following functions can be used to customize the view: 

• To sort the MediaBase by any column heading (such as ID or 
Kill Date) click the desired column heading.  Clicking again 
changes the sort order from ascending ( ) to descending ( ), 
as indicated by the arrow in the heading itself.  

• To rearrange a column, click and drag a column heading to the 
new desired location.

• To change the column width, place your cursor between 
column headings until the double-headed arrow appears.  Click 
and drag the edge to the desired width.

• A MediaBase entry appearing in red text indicates that the 
clip’s kill date has been reached (or has past).

Subclip — A Subclip contains only metadata “pointers,” but 
contains no media.  When played to air, the pointers reference 
start and stop points on the associated Parent clip. 

User — Information to be provided.

Table 2-1. MediaBase Window Icons  (Continued)

Icon Description
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Customize MediaBase Fields
To change the fields that are shown in the MediaBase, right-click any 
column heading to display the Select Fields Dialog:

Figure 2-40. Select Fields Dialog

Check the fields that you want to appear in the MediaBase Window, 
un-check those that you do not want to appear — and click OK.
Descriptions of each field are listed in the table below:

Table 2-2. MediaBase Fields  

Field Description
ID A unique 32 character string used to identify (and 

reference) each clip on the server.  

Description A (maximum) 255 character text description of the 
associated material.

Duration The duration of the clip or subclip, in timecode format.

Kill Date The date on (or after) which the spot should no longer be 
aired.  When a clip reaches its kill date, an alarm appears 
in the PlayList.

Start The timecode of the clip’s first frame of material.
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Note that the MediaBase view, including the names and arrangements 
of columns, is stored by user name.  In this manner, each user can have 
his or her own “custom” MediaBase View, which is recalled when you 
log on to the system.

Family This column identifies the parent of a subclip.

Agency A 15 character description of the Agency that created the 
commercial.  The names of Agencies in use appear in the 
pull-down Agency menu in the New ID Dialog, and new 
ones can also be entered in the Properties Dialog. 

Type A five character field used to categorize clips, such as 
COM, PGM, PROMO, PSA, NET, etc.

Record Date The date and time when the clip was recorded.  This value 
cannot be changed once a clip is recorded.

Codec Recorded The codec (channel) on which the clip was recorded.

Link Indicates a linked clip for the ClipSync application, in 
which a clip loaded in one channel automatically loads 
plays back a linked clip in another channel. 

User Fields 1-4 Four user-definable fields of information, entered in a 
clips Properties Dialog.

Video Format The video format of the recording (MPEG or DV).  If 
MPEG, the profile is also shown.

GOP The complete GOP structure for an MPEG clip.

Data Rate The bitrate for the associated DV or MPEG clip.

User Name The name of the user that recorded the clip.

Media Drive The name of the drive on which the media is stored.

Table 2-2. MediaBase Fields  (Continued)

Field Description
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MediaBase Browse
To browse (or preview) clips in the MediaBase:

• Ensure that your audio/video monitoring is properly set up to 
monitor one of the server’s channels.

• In the Tool Bar, select the desired output channel with the 
pull-down arrow (to the right of the Load button).

• In the MediaBase Window, highlight the clip that you want to 
browse.  You can also use the Find Dialog to help you locate 
clips.  Refer to the “MediaBase Menu” section for details.

• In the Tool Bar, click Load to load and play the highlighted 
clip.  

Remember that clicking Load immediately overrides any clip playing 
in that channel.

MediaBase Properties
Each clip (and subclip) has as associated Clip Properties Dialog that 
contains all clip information, thumbnail images of keyframes plus user 
fields.  There are two ways to display a clip’s Properties Dialog:

• Double-click any clip in the MediaBase Window. 
• Right-click any clip to display the Clip Pop-up Menu:

Figure 2-41. Clip Pop-up Menu

Then click Properties to display the Properties Dialog for the 
selected clip.  The information presented in the dialog is both 
fixed and changeable, and all information can appear in the 
MediaBase Window fields (depending on which fields are 
enabled in the Select Fields Dialog).

Note that the “Show Hidden Clips” and “Delete Clip(s)” functions 
can only be performed by the System Administrator and users with 
“delete” privileges.  See Chapter 6, “Advanced Operations” for details.

Caution
Before you browse clips on a 
channel, ensure that the channel 
is not being used on air.
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A sample Clip Properties Dialog is shown below:

Figure 2-42. Clip Properties Dialog

Descriptions of each section are listed below:
1) The Clip Information Section displays both fixed and 

changeable data obtained at the time of recording or subclip 
creation:

• Fixed fields include Start and Duration, Date Recorded, 
UMID, plus the Owner (user) that recorded the clip.

• Changeable fields include ID, Kill Date, Type and 
Agency.  Type new information as required and click OK.  
If you change the ID, however, you will be asked to 
confirm the change.

1) Clip Information Section 3) A/V Information  Section 4) Image Information Section

2) User Fields Section

1

4

2

3
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2) The User Fields Section displays user-defined fields, including 
the clip Description (up to 255 characters), and four User Fields. 
Type new information as desired and click OK.

3) The A/V Information Section displays video and audio clip 
information obtained at the time of recording (or subclip creation), 
including Video Format, GOP structure, Data Rate, Audio 
Channels and VBI Lines.

4) The Image Information Section displays five “thumbnail” 
images (also called “picons”) that were grabbed from five locations 
evenly spaced throughout the clip — from the inpoint to the 
outpoint.  The associated timecodes are shown.  Note that if you 
generate a subclip from a parent clip, the picons change accordingly 
for the new subclip.

Digitize Window
The Digitize Window is your interface for controlling an external VTR 
that is connected to the server via RS-422 (serial) protocol.  Although 
multiple VTRs can be connected to the server, only one can be 
controlled at a time through the Digitize Window.
Using transport controls similar to those found in a Channel Control 
Window, the Digitize Window allows you to digitize tape segments and 
store them on the server.  Once digitized, the information appears in the 
MediaBase and the TapeBase Windows.
There are three ways to display the Digitize Window:

• On the Menu Bar, click View > Digitize Window.
• On the Tool Bar, click the Digitize icon.
• Within the TapeBase Window, double-click an entry.  Refer to 

the “TapeBase Window” section for details.  
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A sample Digitize Window is shown below:

Figure 2-43. Digitize Window

Descriptions of each section and button are provided below:
1) The Mark In Section provides controls for marking (or entering) 

the point along the tape at which you want to start digitizing.    
• Click Mark to mark an inpoint on the fly.
• Click Goto to search to the marked inpoint.
• Click inside the Timecode field, and enter an entry point 

or a “goto” point.  Numbers shift left as you enter them.

2

1 3

4

5

6

1) Mark In Section 3) Mark Out Section 5) ID Information Section

2) Timecode Section 4) Transport Control Section 6) Function Section
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2) The Timecode section displays the tape segment’s position, 
format (DF or NDF), and status messages specific to the VTR such 
as Rec Inhibit and Local.  

3) The Mark Out Section provides controls for marking (or 
entering) the point at which you want to stop digitizing.  Controls 
are identical to the Mark In Section, except the outpoint is affected.

4) The Transport Control Section provides VTR-like controls:

• Click and drag the Shuttle control (or “slider”) to shuttle 
the tape forwards and backwards.  At the left, the speed 
indicator shows the percentage of normal play speed.

Click Eject to eject the tape cassette.

Click Rewind to shuttle the tape at full-speed reverse.

Click Reverse to play at one times play speed, in 
reverse.

Click Step Left to jog the tape backwards by one 
frame.    

Click Pause to stop tape playback on a freeze frame.

Click Step Right to jog forwards by one frame.

Click Play to play the tape at one times play, forward.

Click Fast Forward to shuttle the tape at full-speed 
forward.

Click Stop to stop tape playback.
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When you release the control, it remains at its current 
direction and speed until changed (or until overridden by 
another transport control).

• Enable the CTRL TRACK check box to use control track 
pulses to position the tape.  Disable the check box to use 
timecode, for frame-accurate tape positioning.

• Enable the SDTI check box to digitize an SDTI stream and 
automatically convert it to DV format.  You will be asked 
to confirm your selection.  
An SDTI compatible tape deck is required.  Several models 
of SDTI decks are supported.  Please contact Leitch 
Technical Support for details.    
Note that 1x and 4x normal speed transfers are supported 
for DV25, and 1x normal speed transfer is supported for 
DV50.  Transfer speeds must be selected at the SDTI tape 
deck itself.  

• Right-click the channel label to display the Channel Select 
Pop-up Menu:

Figure 2-44. Channel Select Pop-up Menu

Select the channel to which you want to digitize.  Once 
selected, the channel label changes — both in the Transport 
Control Section and at the bottom of the window.

5) The ID Information Section provides text fields for the digitized 
clip’s ID, Description, Agency, Type, Kill Date, Tape #, Store 
Room and Bin.  Four additional timecode fields are provided:

• The SRC IN field is identical to the timecode field in the 
Mark In section.

• The SRC DUR field is the difference between the marked 
inpoint and outpoint, but if you enter a timecode in the SRC 
DUR field, the outpoint is recalculated.

• The START+ field is currently not implemented. 
• The RUN DUR field is currently not implemented. 

Note
An SDTI stream can only be 
digitized when the server 
channel is set to DV.  Contact 
your System Administrator for 
assistance with channel format.

Note
Press TAB (and SHIFT + TAB) 
to move between timecode 
fields.  TAB works in place of 
the Enter key to accept a 
timecode value. 
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• The Format, GOP and Bitrate fields reflect the current 
compression settings, as defined within the Compression 
Settings Dialog.  Refer to the “Compression Settings” 
section for details.

6) The Function Section includes four buttons used to start the 
digitizing, update the TapeBase, change compression or cancel.  

• Click Digitize to start the digitizing process.  The button 
lights red when the mode is active.  If the VTR is not 
connected, a warning dialog appears.

• Click Update to create an entry in the TapeBase Window 
based on the timecode marks and associated data in the 
Digitize Window.  The TapeBase entry can be used to 
digitize (or re-digitize) the material at a later time.  Refer to 
the “TapeBase Window” section for additional information.  

• Click Cancel to halt the digitizing process.
• Click Compression Settings to change the video 

compression settings for the segment to be digitized.  The 
Compression Settings Dialog appears.  Refer to the 
“Compression Settings” section for details.
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TapeBase Window
The TapeBase Window provides a convenient way for users to 
re-digitize material that has been removed from the server.  Typically, 
with limited room on the RAID set, a facility will delete spots that have 
reached their kill dates to make room for new material.  The masters 
will then be stored in a tape vault.  If an old clip is needed again, the 
TapeBase knows the original tape’s location in the vault, along with the 
clip’s original marks.  
To re-digitize the clip, locate it in the TapeBase, locate the physical tape 
in the vault, load it in the tape deck and double-click the desired 
TapeBase entry.  The original marks are recalled to the Digitize 
Window — click Digitize to load it back to the server. 
The figure below illustrates a sample TapeBase Window: 

Figure 2-45. TapeBase Window

Columns are provided for ID, Description, Duration, Source In, 
Agency, Type, Kill Date, Tape #, Store Room and Bin (every field in the 
associated Digitize Window).
Please note:

• The Status field indicates the clip’s status in relation to the 
RAID set (for example, Offline, Online, etc.).

• To sort the TapeBase by any column heading (such as ID or 
Kill Date) click the desired heading.  Clicking again changes 
the sort order from ascending ( ) to descending ( ) order.

• Double-click any line to recall that data to the Digitize 
Window, enabling you to digitize the selected tape segment.
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• SHIFT + Click and CTRL + Click selection methods function 
in the normal manner for making multiple selections.

TapeBase Menu
When the TapeBase Window is active, the Menu Bar changes to show 
the TapeBase Menu: 

Figure 2-46. TapeBase Menu

Note that the identical menu can be displayed by right-clicking on any 
column heading in the TapeBase Window.  Using the menu, you can:

• Click Delete (or press the Delete key) to delete a highlighted 
segment in the list.  You will be asked to confirm your choice.

• Click Delete All to delete all segments in the list.  You will be 
asked to confirm your choice.

• Click Import to display the Import TapeBase File Dialog, 
from which you can import a TapeBase file that was saved to 
disk.  This function allows you to transfer TapeBase files from 
server to server, if required. 

• Click Export to display the Export TapeBase File Dialog, 
from which you can save a TapeBase file to disk.  
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GPI Window
The GPI Window provides up to five tabs — one for each channel in 
your system and one “global” tab that pertains to all GPI (General 
Purpose Interface) channels.  Using the channel tabs, you can control 16 
discreet GPI input signals and eight discreet GPI output signals.
The figure below illustrates one of the four identical GPI Channel 
Tabs:

Figure 2-47. GPI Channel Tab

With each GPI Channel Tab, you can:
• Assign up to 16 GPI input signals to perform various channel or 

PlayList functions — PlayList Start, PlayList Stop, PlayList 
Recue, PlayList Next, CH Record, CH Record with ID 
Increment, CH Stop and CH Play.  
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For example, the master control operator can press a button that 
triggers a GPI to start, stop or recue a PlayList.  

• Assign a PlayList action to control up to eight GPI output 
signals.  PlayList actions include PlayList Start and PlayList 
Stop.  For example, when a PlayList stops, a GPI could be used 
to trigger the master control switcher to cut back to the 
network.

• Check or un-check the Enable Input GPI check box to enable 
or disable all input GPIs for that channel.

• Check or un-check the Enable Output GPI check box to 
enable or disable all output GPIs for that channel.  

• Assign a single GPI to perform different tasks on different 
channels.  For example, GPI #1 stops a PlayList on Channel 1 
and starts a PlayList on Channel 2. 

• Set a Trigger Offset value (in frames) for the “PlayList Start” 
and “PlayList Stop” functions.  These values let you shift the 
triggers in relation to the PlayList, for example, if you wanted 
to bring in a logo prior to (or after) the start of the PlayList. 
Trigger and pulse duration ranges are listed below:

Table 2-3. GPI Trigger and Pulse Duration Ranges (in frames)

Value Trigger Offset GPI Duration
PlayList Start 0 to 160 0 to 10

PlayList Stop -160 to +160 0 to 10

Note
Refer to the Leitch Server’s 
“Installation Manual” for details 
on GPI installation and pinouts.
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The figure below illustrates the ALL GPIs Tab:

Figure 2-48. ALL GPIs Tab

The ALL GPIs Tab is a test application designed to monitor and check 
GPI input and output signals and messages.  
No operator controls are provided.  
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